Pixhawk un seul moteur marche.
Forum Multirotors et Drones
MikroKopter de MeKam
Merci de vous connecter ou de vous inscrire.

Connexion avec identifiant, mot de passe et durée de la session

Auteur Sujet: Pixhawk un seul moteur marche.  (Lu 1201 fois)

patrice60200

  • Nouveau
  • *
  • Hors ligne Hors ligne
  • Messages: 6
  • Envie d'apprendre
Pixhawk un seul moteur marche.
« le: 24 octobre 2017 à 21:48:31 »

Bonsoir,
Je viens aupres de vous, car je suis entrain de m'arracher les cheveux.
je souhaite installer un autopilote sur un bateau amorceur composé de deux moteurs.
Mon but et un jour de pecher avec mon petit bateau sur des watpoints enregistrés, dou autopilot pixhawk.
jai donc acheté un kit pixhawk sur ebay.


jai installé mission planner , branché le pixhawk  , jai la graupner  mx20 et le recepteur gr 24 de graupner.

mon but et de faire fonctionner mes deux moteur, apres faire un mixage .
deja faire marcher mon bateau avec pixhawk .

jai donc parametré mon gr 24 en mode sumo. comme vous le voyez sur la photo, jai branché un cable servo qui va de la sortie 8 du recepteur sur le pixhawk entréé rc IN.
jai apres branché mes deux variateur de vitesse sur les entrés  main out de mon pixhawk.

radio en mode 1, 2 , 3 ou 4 gaz a gauche ou a droite, un seul moteur tourne.
mes esc ont eté armés avec le bouton switch branché sur pixhawk.
ma radio commande a eté calibré dans mission planner, car en actionnant les manches de gaz, je vois bien dans radio calibration les  trait vert qui bougent.

en resumé, jai un seul moteur qui tourne en actionnant la manche de gaz, une seul voie qui semble fonctionné sur pixhawk, la voie numero 1 de main out  ou es branché lun de esc, je 2 eme est branché sur la voie  2.
Les deux moteurs tournent sans probleme quand je les branche en direct sur mon recepteur via mes deux esc.

Mon but et donc de faire un autopilot pour mon bateau amorceur equipé de deux moteur,  deux esc  et quelques servo.

je suis perdu, je sais pas comment proceder, aidez moi a tout bien installer.

jai mis des photos, mais je sais pas si ca va marcher
IP archivée
patrice

infobarque

  • Membre Complet
  • ****
  • Hors ligne Hors ligne
  • Messages: 279
    • Environnement Drone
Pixhawk un seul moteur marche.
« Réponse #1 le: 25 octobre 2017 à 17:54:02 »

IP archivée
phantom 1.2 5.8gz
phantom 2
fy680 made in mes mains
environnement drone http://environnementdrone.com

patrice60200

  • Nouveau
  • *
  • Hors ligne Hors ligne
  • Messages: 6
  • Envie d'apprendre
Pixhawk un seul moteur marche.
« Réponse #2 le: 25 octobre 2017 à 19:38:32 »

bonjour,
tu es en mode rover?
jète un oeil http://ardupilot.org/rover/docs/skid-steer-parameter-tuning.html



bonsoir, oui effectivement je suis en mode rover.
mon but et de faire fonctionner les deux moteurs, pour linstant ya q'un seul moteur qui marche, branché sur la voie 1 de main out. en actionnant la manche de gaz sur la telecommande, le moteur tourne, mais impossible de faire tourner le 2eme moteur branché sur la voie 2 de main out.

Disant aucune des autres voie de main out fonctionne a par la voie 1.
est ce que c'est normal?
aucune aussi de voie aux out ne foctionne .
ET le voyant(led de pixhawk ) clignote jaune car c'est marqué disarmed sur mission planner meme apres avoir armer les moteur par le bouton switch.
les moteur bip et arrete de bipper.


merci pour le lien, je regarde ca et essaie de mettre en pratique, je vous tiens rapidement  au courant.
IP archivée
patrice

Francklin

  • Membre Héroïque
  • ******
  • Hors ligne Hors ligne
  • Messages: 8 458
  • C'est moins intelligent qu'un Nao mais ca vole
Pixhawk un seul moteur marche.
« Réponse #3 le: 25 octobre 2017 à 20:26:56 »

Commrnt fonctionne ta direction ? tu veux la faire avec les 2 moteurs ou tu as un safran en plus ?
Normalement tu as droit a 1 voie gaz et une voie direction
http://ardupilot.org/rover/docs/common-pixhawk-wiring-and-quick-start.html
si tu n'as pas de safran faut passer en mode "tank" pour piloter les 2 moteurs
Citer
For Rovers connect the throttle and steering wires to the main output signal pins:

Pin 3 = Throttle
Pin 1 = Steering
The skid-steer parameters are used to configure vehicles that have fixed wheels and steer like tank tracks (do not use servos to steer the wheels but rather use differential speed between the left and right wheels). The parameters are: SKID_STEER_OUT and SKID_STEER_IN. When enabled, flight controller’s ouput RC1 is used for the left track control, and ouput RC3 is used for right track control.
« Modifié: 25 octobre 2017 à 20:32:33 par Francklin »
IP archivée
Multiwii: Mini hexa Y6,Quadri pliable QC450
Arducopter APM 2.5: FlyduSpider, Quadri caréné
Mikrokopter: Quad XXL , FrankenQuad XL, Soucoupe Hexa caréné 1m, Hexastar 700 Nacelle 360° AV130 de chez 1001copters

patrice60200

  • Nouveau
  • *
  • Hors ligne Hors ligne
  • Messages: 6
  • Envie d'apprendre
Pixhawk un seul moteur marche.
« Réponse #4 le: 26 octobre 2017 à 17:35:01 »

Commrnt fonctionne ta direction ? tu veux la faire avec les 2 moteurs ou tu as un safran en plus ?
Normalement tu as droit a 1 voie gaz et une voie direction
http://http://ardupilot.org/rover/docs/common-pixhawk-wiring-and-quick-start.html
si tu n'as pas de safran faut passer en mode "tank" pour piloter les 2 moteurs
Citer
For Rovers connect the throttle and steering wires to the main output signal pins:

Pin 3 = Throttle
Pin 1 = Steering
The skid-steer parameters are used to configure vehicles that have fixed wheels and steer like tank tracks (do not use servos to steer the wheels but rather use differential speed between the left and right wheels). The parameters are: SKID_STEER_OUT and SKID_STEER_IN. When enabled, flight controller’s ouput RC1 is used for the left track control, and ouput RC3 is used for right track control.




Bonjour ,
oui effectivenet je voudrais le faire marcher comme un tank, jai deux moteus.
en regardant ce lien
http://ardupilot.org/rover/docs/common-pixhawk-wiring-and-quick-start.html
est ce que c'est pas moi qui fait mal mes connections?
dites moi, est ce que les deux  esc doivent etre branchés directement sur px4 c'est a dire sur les sorties 1 et 3 de main out
Pin 3 = Throttle
Pin 1 = Steering
pour avoir  lacceleration et la direction sur les deux manches de ma radio?
c'est ce que jai fait, jai branché les deux cables servo de mes esc directement sur pix 4 sur les sorties 1 et 3.
mais jai enlevé le cable +, il reste le signal et le moins branchés.
Mais il se passe rien quand jactionne les manche de gaz de ma radio.
sur le recepteur je branche rien?
car mon recepteur et branché sur le pix en mode sumo que jai reglé directement depuis la radio.
un cable servo va de mon recepteur sur le px4 a sa sortie rc in.
Mais rien ne marche. le vois bien ma radio , c'est a dire les voyant vert actionnés dans calibrage radio de px4.
Mais aussi, pourquoi le voyant reste en jaune sur px4? 
il arrete pas de clignoter deux fois en jaune.

Ha une chose que jai remarqué, en tatonant dans mes branchement sur certaines entrées de main out de px 4, quand je branche le cable esc et que je le retire, le moteur tourne 1 seconde et s'arette aussitot.
besoin de votre aide.
jai oublié de faire quelque chose?

http://ardupilot.org/rover/index.html


IP archivée
patrice

patrice60200

  • Nouveau
  • *
  • Hors ligne Hors ligne
  • Messages: 6
  • Envie d'apprendre
Pixhawk un seul moteur marche.
« Réponse #5 le: 26 octobre 2017 à 19:08:02 »

Commrnt fonctionne ta direction ? tu veux la faire avec les 2 moteurs ou tu as un safran en plus ?
Normalement tu as droit a 1 voie gaz et une voie direction
http://http://ardupilot.org/rover/docs/common-pixhawk-wiring-and-quick-start.html
si tu n'as pas de safran faut passer en mode "tank" pour piloter les 2 moteurs
Citer
For Rovers connect the throttle and steering wires to the main output signal pins:

Pin 3 = Throttle
Pin 1 = Steering
The skid-steer parameters are used to configure vehicles that have fixed wheels and steer like tank tracks (do not use servos to steer the wheels but rather use differential speed between the left and right wheels). The parameters are: SKID_STEER_OUT and SKID_STEER_IN. When enabled, flight controller’s ouput RC1 is used for the left track control, and ouput RC3 is used for right track control.




Bonjour ,
oui effectivenet je voudrais le faire marcher comme un tank, jai deux moteus.
en regardant ce lien
http://http://ardupilot.org/rover/docs/common-pixhawk-wiring-and-quick-start.html
est ce que c'est pas moi qui fait mal mes connections?
dites moi, est ce que les deux  esc doivent etre branchés directement sur px4 c'est a dire sur les sorties 1 et 3 de main out
Pin 3 = Throttle
Pin 1 = Steering
pour avoir  lacceleration et la direction sur les deux manches de ma radio?
c'est ce que jai fait, jai branché les deux cables servo de mes esc directement sur pix 4 sur les sorties 1 et 3.
mais jai enlevé le cable +, il reste le signal et le moins branchés.
Mais il se passe rien quand jactionne les manche de gaz de ma radio.
sur le recepteur je branche rien?
car mon recepteur et branché sur le pix en mode sumo que jai reglé directement depuis la radio.
un cable servo va de mon recepteur sur le px4 a sa sortie rc in.
Mais rien ne marche. le vois bien ma radio , c'est a dire les voyant vert actionnés dans calibrage radio de px4.
Mais aussi, pourquoi le voyant reste en jaune sur px4? 
il arrete pas de clignoter deux fois en jaune.

Ha une chose que jai remarqué, en tatonant dans mes branchement sur certaines entrées de main out de px 4, quand je branche le cable esc et que je le retire, le moteur tourne 1 seconde et s'arette aussitot.
besoin de votre aide.
jai oublié de faire quelque chose?

http://http://ardupilot.org/rover/index.html



Pourtant mes esc arrivent a s'armer sans soucie, quand j'appuie sur le bouton rouge switch, les esc s'arment et arrete de bipper, je comprend pas pourquoi j'arrive pas a faire tourner mes moteurs avec ma radiocommande quand les esc sont branchés directement sur les sorties mains out de pixhawk.
IP archivée
patrice

patrice60200

  • Nouveau
  • *
  • Hors ligne Hors ligne
  • Messages: 6
  • Envie d'apprendre
Pixhawk un seul moteur marche.
« Réponse #6 le: 31 juillet 2018 à 20:59:46 »

Bonsoir. Après quelques mois d'absence, je reviens sur le site avec une bonne nouvelle..
Dans un premier temps j'avais changé de radio commande.

Je suis passé au célèbre taranais x9d.apres plusieurs réglages et recherches, mon bateau amorcer équipé de l'autopilote pix4  fonctionne maintenant très bien apres plusieurs réglages et plusieurs essaies.

Je peux créer des missions et actionner le mode automatique.

Je vous mettrais une vidéo.

Mais, il ya toujours un mais.
Le problème que je rencontre actuellement quand j'actionne que le mode auto avec Retour To launch comme dernier waytpoint, le bateau  va faire tout les waytpoint et reviendra à son point de départ , normal car RTL  et le dernier waytpoint .

Mais si j'actionne seulement le mode RTL, le bateau revient au point de départ mais va faire de cercle .

En résumé RTL a la fin des waytpoint, en mode automatique de bateau revient et ne fais pas de cercle.
Mais si j'actionne que le mode RTL avec un bouton sur la radio commande le bateau revient et commence à faire des cercles.
Comment je peux éviter qu'il fasse des rond ou cercles? y a-t-il quelque chose à enlever dans mission planner pour éviter qu'il puisse faire des ronds  quand il es rentré?
Merci de m'aider..
IP archivée
patrice

Francklin

  • Membre Héroïque
  • ******
  • Hors ligne Hors ligne
  • Messages: 8 458
  • C'est moins intelligent qu'un Nao mais ca vole
Pixhawk un seul moteur marche.
« Réponse #7 le: 01 août 2018 à 20:26:00 »

Tu dois avoir une Loiter qui est activé sur le RTL, regarde si tu peux jouer sur le RTL_LOIT_TIME  :hmmm:

http://ardupilot.org/copter/docs/rtl-mode.html

« Modifié: 01 août 2018 à 20:53:48 par Francklin »
IP archivée
Multiwii: Mini hexa Y6,Quadri pliable QC450
Arducopter APM 2.5: FlyduSpider, Quadri caréné
Mikrokopter: Quad XXL , FrankenQuad XL, Soucoupe Hexa caréné 1m, Hexastar 700 Nacelle 360° AV130 de chez 1001copters