Nano Racing et Futaba : problème de config via BetaFlight
Forum Multirotors et Drones
MikroKopter de mikrocam
Merci de vous connecter ou de vous inscrire.

Connexion avec identifiant, mot de passe et durée de la session

Auteur Sujet: Nano Racing et Futaba : problème de config via BetaFlight  (Lu 177 fois)

Marko_33

  • Membre Complet
  • ****
  • Hors ligne Hors ligne
  • Messages: 371
Nano Racing et Futaba : problème de config via BetaFlight
« le: 09 juillet 2017 à 12:44:00 »

Bonjour,

J'avais commandé mon nano-racer pour voler avec un module Fr-Sky sur une Eurgle.
J'ai cramé la Eurgle avec un mauvais branchement de Lipo.

J'essaie de configurer le nano via betaflight pour voler avec une Futaba T8J (S-FHSS) avec un module KS-Servo SF800, en me basant sur un tuto trouvé sur la page de support de nano-racing : https://www.dropbox.com/s/jk574mqvrinlobo/Nano%26Futaba.pdf?dl=0

Voilà où j'en suis :
- Bind T8J - SF800 OK
- Configuration récepteur en SBUS : OK
- Configuration Betaflight en SERIAL RX sur UART3 OK (voir image ci-dessous) : à priori OK (je ne sais pas trop ce qu'il faut faire avec le MSP)

Problème : je n'ai pas l'impression que le nano reçoive les commandes de la radio, quel que soit le channel map que je sélectionne.

Pouvez-vous m'aider ?

https://www.dropbox.com/s/3v5srq2spjwr3mv/configuration.jpg?dl=0
https://www.dropbox.com/s/tv90emfpfjkzups/Ports.jpg?dl=0
https://www.dropbox.com/s/esgsvb35wv0qi85/receiver.jpg?dl=0
IP archivée
Tarot fy-650 / Naza M V2 / T-Motor MT2216-12 800KV / DJI-ESC30A / hélices 11x3,7"  T-Motor
Nacelle Tarot T-2D / GOPRO Hero 3+ Black Edition
Futaba T8J

Nano Racer Early Bird
Hubsan X4 H107L
Cheerson CX-10A

touchthebitum

  • Membre Senior
  • *****
  • Hors ligne Hors ligne
  • Messages: 583
  • Toujours plus léger
    • Créations 3D Thingiverse
Nano Racing et Futaba : problème de config via BetaFlight
« Réponse #1 le: 10 juillet 2017 à 08:19:55 »

Salut
As-tu essayé l'inversion du signal SBUS via le CLI ?
Tu vas dans le CLI et tu tapes :
set sbus_inversion = OFF  ou = ON
N'oublie pas de faire "save" en sortant et tu testes ....

P.S Ne désactive pas le MSP car ça te permet de te connecter en usb.....
IP archivée
Quad Aerial MOB  VrBrain 5.2 Taranis X9D Haptic+Speaker MOD
ZMR250 FPV + Quad Franck Imprimante 3D FPV
VrBrain 4.5 433mhz telemetry + Mobius FPV/Canon SX280 HS CHDK
(2d/3d guardian, Ruby uThere, Skylark OSD)
Impression 3D Prusa i3 Hephestos version 200x300, palpeur effet Hall/autonivellation, lit chauffant, etc...

Marko_33

  • Membre Complet
  • ****
  • Hors ligne Hors ligne
  • Messages: 371
Nano Racing et Futaba : problème de config via BetaFlight
« Réponse #2 le: 12 juillet 2017 à 11:16:58 »

Merci pour ton aide.

Je n'ai pas essayé via le CLI.

Mais je vais tester.

c'est quoi cette commande SBUS_inversion ?

Pour le MSP, j'ai tenté de le désactiver le de mon premier essai (je n'avais pas bien compris le tuto du support).
Mais il a refuser de le faire. Le MSP est toujours activé sur le UART1.
et j'ai activé le RX_Level sur UART3.
IP archivée
Tarot fy-650 / Naza M V2 / T-Motor MT2216-12 800KV / DJI-ESC30A / hélices 11x3,7"  T-Motor
Nacelle Tarot T-2D / GOPRO Hero 3+ Black Edition
Futaba T8J

Nano Racer Early Bird
Hubsan X4 H107L
Cheerson CX-10A

touchthebitum

  • Membre Senior
  • *****
  • Hors ligne Hors ligne
  • Messages: 583
  • Toujours plus léger
    • Créations 3D Thingiverse
Nano Racing et Futaba : problème de config via BetaFlight
« Réponse #3 le: 12 juillet 2017 à 11:30:55 »

De rien ;)
L'inversion s-bus inverse simplement le signal et pourrait être la cause du problème ;)
IP archivée
Quad Aerial MOB  VrBrain 5.2 Taranis X9D Haptic+Speaker MOD
ZMR250 FPV + Quad Franck Imprimante 3D FPV
VrBrain 4.5 433mhz telemetry + Mobius FPV/Canon SX280 HS CHDK
(2d/3d guardian, Ruby uThere, Skylark OSD)
Impression 3D Prusa i3 Hephestos version 200x300, palpeur effet Hall/autonivellation, lit chauffant, etc...

Marko_33

  • Membre Complet
  • ****
  • Hors ligne Hors ligne
  • Messages: 371
Nano Racing et Futaba : problème de config via BetaFlight
« Réponse #4 le: 13 juillet 2017 à 15:17:59 »

Bon, ça ne fonctionne toujours pas...

J'ai activé / désactivé SBUS_inversion. pas de réaction du drone.

Je ne sais pas si le problème vient du drone, ou alors de la configuration de ma radio (je ne suis pas très à l'aise là dedans).
Mais elle fonctionne très bien avec mon Tarot.

Je poste ci-dessous la config.
Peux-être verrez vous une coquille de conf :





IP archivée
Tarot fy-650 / Naza M V2 / T-Motor MT2216-12 800KV / DJI-ESC30A / hélices 11x3,7"  T-Motor
Nacelle Tarot T-2D / GOPRO Hero 3+ Black Edition
Futaba T8J

Nano Racer Early Bird
Hubsan X4 H107L
Cheerson CX-10A

touchthebitum

  • Membre Senior
  • *****
  • Hors ligne Hors ligne
  • Messages: 583
  • Toujours plus léger
    • Créations 3D Thingiverse
Nano Racing et Futaba : problème de config via BetaFlight
« Réponse #5 le: 13 juillet 2017 à 15:25:37 »

Tu as bien fait "save" dans le CLI avant de quitter ? Je me suis fait avoir plusieurs fois.
Sinon, pourrais-tu copier le texte du CLI, le copier dans un fichier txt et le poster ?
Merci
IP archivée
Quad Aerial MOB  VrBrain 5.2 Taranis X9D Haptic+Speaker MOD
ZMR250 FPV + Quad Franck Imprimante 3D FPV
VrBrain 4.5 433mhz telemetry + Mobius FPV/Canon SX280 HS CHDK
(2d/3d guardian, Ruby uThere, Skylark OSD)
Impression 3D Prusa i3 Hephestos version 200x300, palpeur effet Hall/autonivellation, lit chauffant, etc...

Marko_33

  • Membre Complet
  • ****
  • Hors ligne Hors ligne
  • Messages: 371
Nano Racing et Futaba : problème de config via BetaFlight
« Réponse #6 le: 13 juillet 2017 à 16:04:14 »

Tu as bien fait "save" dans le CLI avant de quitter ? Je me suis fait avoir plusieurs fois.
Sinon, pourrais-tu copier le texte du CLI, le copier dans un fichier txt et le poster ?
Merci

Alors, dans le CLI, il n'y a pas de "save".
alors j'allais dans un autre menu pour faire save.

OK, je vais copier le retour du CLI, mais il confirme bien la prise en compte de commande avec un texte du genre : "SBUS_inversion set to ON"
IP archivée
Tarot fy-650 / Naza M V2 / T-Motor MT2216-12 800KV / DJI-ESC30A / hélices 11x3,7"  T-Motor
Nacelle Tarot T-2D / GOPRO Hero 3+ Black Edition
Futaba T8J

Nano Racer Early Bird
Hubsan X4 H107L
Cheerson CX-10A

touchthebitum

  • Membre Senior
  • *****
  • Hors ligne Hors ligne
  • Messages: 583
  • Toujours plus léger
    • Créations 3D Thingiverse
Nano Racing et Futaba : problème de config via BetaFlight
« Réponse #7 le: 13 juillet 2017 à 16:07:23 »

il faut l'écrire
IP archivée
Quad Aerial MOB  VrBrain 5.2 Taranis X9D Haptic+Speaker MOD
ZMR250 FPV + Quad Franck Imprimante 3D FPV
VrBrain 4.5 433mhz telemetry + Mobius FPV/Canon SX280 HS CHDK
(2d/3d guardian, Ruby uThere, Skylark OSD)
Impression 3D Prusa i3 Hephestos version 200x300, palpeur effet Hall/autonivellation, lit chauffant, etc...

ulix

  • Membre Senior
  • *****
  • Hors ligne Hors ligne
  • Messages: 596
Nano Racing et Futaba : problème de config via BetaFlight
« Réponse #8 le: 13 juillet 2017 à 16:14:08 »

salut

L inversion de signal jai ce problème sur les F4 et pas les F3

Sur un FM800 copie futaba que  l'on trouve chez BG il est possible d'avoir le signal inversé.

https://community.micro-motor-warehouse.com/t/alienflightng-f4/3124

a++
IP archivée
Radio Futaba T18
Tricopter (IMU) William.DE

Du naze 32

Marko_33

  • Membre Complet
  • ****
  • Hors ligne Hors ligne
  • Messages: 371
Nano Racing et Futaba : problème de config via BetaFlight
« Réponse #9 le: 13 juillet 2017 à 17:06:04 »

moi j'ai acheté un SF800 chez Bangood (cause T8J en S-FHSS), donc potentiellement le même problème.
IP archivée
Tarot fy-650 / Naza M V2 / T-Motor MT2216-12 800KV / DJI-ESC30A / hélices 11x3,7"  T-Motor
Nacelle Tarot T-2D / GOPRO Hero 3+ Black Edition
Futaba T8J

Nano Racer Early Bird
Hubsan X4 H107L
Cheerson CX-10A

ulix

  • Membre Senior
  • *****
  • Hors ligne Hors ligne
  • Messages: 596
Nano Racing et Futaba : problème de config via BetaFlight
« Réponse #10 le: 13 juillet 2017 à 21:07:33 »

Ta pas la possibilité de voir sur une autre FC en F3 et ta FC c est une quoi?

moi j'ai acheté un SF800 chez Bangood (cause T8J en S-FHSS), donc potentiellement le même problème.
IP archivée
Radio Futaba T18
Tricopter (IMU) William.DE

Du naze 32

Marko_33

  • Membre Complet
  • ****
  • Hors ligne Hors ligne
  • Messages: 371
Nano Racing et Futaba : problème de config via BetaFlight
« Réponse #11 le: 16 juillet 2017 à 21:02:54 »

la carte est une flex FC "maison" (je crois) :
https://www.dropbox.com/s/87jy2o2ym5qwfp5/nano-notice-brushless-sbus.pdf?dl=0

Je n'ai pas de F3 sous la main.
Je n'ai que mon Tarot avec un NAZA V2 que j'utilise en pro, alors pas trop envie de toucher à la config qui fonctionne bien.
« Modifié: 16 juillet 2017 à 21:05:11 par Marko_33 »
IP archivée
Tarot fy-650 / Naza M V2 / T-Motor MT2216-12 800KV / DJI-ESC30A / hélices 11x3,7"  T-Motor
Nacelle Tarot T-2D / GOPRO Hero 3+ Black Edition
Futaba T8J

Nano Racer Early Bird
Hubsan X4 H107L
Cheerson CX-10A