Forum Multirotors et Drones

Pour ceux qui commencent ;-) => Nos Multirotors => Discussion démarrée par: DarkSmall le 05 janvier 2018 à 12:07:01

Titre: Problème quad TAROT 650 avec PixHawk - programmation
Posté par: DarkSmall le 05 janvier 2018 à 12:07:01
Bonjour à tous,

Bien comme je le disais dans la partie présentation, je suis actuellement en pleine configuration de mon quad ironman650, avec une pixhawk.
La construction s'est très bien passé, me manque encore de recevoir la gimbal mais ca peut attendre je pense.
Arrive le moment où j'allume pour la première fois le px.
La tout se passe bien, il reconnait bien l'usb, missionplanner aussi. Je suis le tuto pour bien configurer le px, et là arrive le moment où je calibre mes ESC. Pas de soucis, il chante, les moteurs tournent, c'est super!

Cependant, au moment d'armer les moteurs rien n'y fait. Je retente plusieurs fois, j'enlève même le "test prearm" de la carte, mais rien ne s'arme, le son erreur d'armement retenti sans arrêt.
Puis je décide de recommencer le calibrage des esc, mais le bouton safety switch, ne semble plus clairer rouge, je n'ai pas l'impression qu'il soit opérant, impossible de recommencer mon calibrage.

Colère je suis, mais patient je reste. Je pense faire un hardreset de mon px. Rien de bien compliquer normalement, mais là, une fois dans le terminal, c'est des lignes de codes infinis et en martien qui s'affiche impossible d'avoir un dump fixe...

Avez vous une idée sur la source du soucis et surtout si vous avez des méthodes supplémentaires... Je pensais effacer la carte SD mais je sais pas du tout si c'est une bonne idée...

Je suis dispo pour toutes questions nécessaire aux diagnostics...
Merci d'avance, j'ai tellement hâte de le faire voler.
Titre: Problème quad TAROT 650 avec PixHawk - programmation
Posté par: furynick le 05 janvier 2018 à 16:10:26
Il suffit de lire le message dans MP, il t'indique clairement pourquoi il refuse d'armer.

Je parie sur Inconsistent Compass !
Titre: Problème quad TAROT 650 avec PixHawk - programmation
Posté par: DarkSmall le 06 janvier 2018 à 14:41:53
Merci pour ta réponse tout d'abords

En effet au début j'essayais de résoudre les soucis mentionner dans le MP. Mais à un moment, plus moyen car le safety switch ne répondait plus... Et c'est à se moment où j'ai désactiver le prearm test...

Pense que je doives remettre le pre arm et me concentrer uniquement sur les indications du pourquoi il refuse d'armer? En oubliant les lignes de commandes incompréhensible et infini du terminal?
Titre: Problème quad TAROT 650 avec PixHawk - programmation
Posté par: furynick le 06 janvier 2018 à 16:31:16
Pourquoi donc le terminal ?
Les messages sont clairement indiqués sur le HUD de MP.
Titre: Problème quad TAROT 650 avec PixHawk - programmation
Posté par: DarkSmall le 06 janvier 2018 à 19:34:13
Le soucis au départ c'est que je souhaitais faire un reset total de mon PX. Et pour ça j'avais besoin d'aller dans le terminal. Je pensais que ca m'aiderait à résoudre mon soucis de safety switch et d'armement, si j'avais mal fait un paramétrage.

Je vais retenter avec le préarm test, et résoudre les erreurs indiquées sur le HUD. On verra bien..